Export (0) Print
Expand All

<compatibleFrameworks> Element (ClickOnce Deployment)

Identifies the versions of the .NET Framework where this application can install and run.

Note Note

MageUI.exe does not support the compatibleFrameworks element when saving an application manifest that has already been signed with a certificate using MageUI.exe. Instead, you must use Mage.exe.

<compatibleFrameworks
      SupportUrl> 
   <framework
      targetVersion
      profile
      supportedRuntime
   /> 
</ compatibleFrameworks>

The compatibleFrameworks element is required for deployment manifests that target the ClickOnce runtime provided by .NET Framework 4 or later. The compatibleFrameworks element contains one or more framework elements that specify the .NET Framework versions on which this application can run. The ClickOnce runtime will run the application on the first available framework in this list.

The following table lists the attribute that the compatibleFrameworks element supports.

Attribute

Description

S upportUrl

Optional. Specifies a URL where the preferred compatible .NET Framework version can be downloaded.

Required. The following table lists the attributes that the framework element supports.

Attribute

Description

targetVersion

Required. Specifies the version number of the target .NET Framework.

profile

Required. Specifies the profile of the target .NET Framework.

supportedRuntime

Required. Specifies the version number of the runtime associated with the target .NET Framework.

The following code example shows a compatibleFrameworks element in a ClickOnce deployment manifest. This deployment can run on the .NET Framework 4 Client Profile. It can also run on the .NET Framework 4 because it is a superset of the .NET Framework 4 Client Profile.

  <compatibleFrameworks xmlns="urn:schemas-microsoft-com:clickonce.v2">
    <framework 
        targetVersion="4.0" 
        profile="Client" 
        supportedRuntime="4.0.30319" />
  </compatibleFrameworks>
Show:
© 2014 Microsoft