Export (0) Print
Expand All

MinRuntimeVersion (Silverlight Plug-in Object)

Silverlight

Sets a value that indicates the earliest Silverlight version that is required in order to run a Silverlight-based application.

object Element

<object ...>
  <param name="minRuntimeVersion" value="version"/>
  ...
</object>

Silverlight.js

Silverlight.CreateObject(,,,{minRuntimeVersion:'version'});
-or-
Silverlight.CreateObjectEx({properties:{minRuntimeVersion:'version'}})

JavaScript

Not available.

COM

Not available.

Managed Code

Not available.

The version of Silverlight that is required by the application. The default is the currently installed version, or null if Silverlight is not installed.

The format of the version string is described in the IsVersionSupported topic.

If an upgrade is required, the Silverlight plug-in displays the message "Click to install the required version". Additionally, if you set the AutoUpgrade property to true, the plug-in will prompt the user to upgrade and then to restart the Web browser.

If an upgrade is required, the following errors occur, regardless of the AutoUpgrade setting:

  • 8001 - Upgrade required.

  • 8002 - Browser restart required.

You can respond to these errors in an OnError handler in order to display your own upgrade and browser restart messages.

Community Additions

ADD
Show:
© 2014 Microsoft