Export (0) Print
Expand All

Redistributing an Application and Binding It to Specific Libraries

Visual Studio 2008

Updated: July 2008

The libraries for Visual Studio often are updated after a release. For example, this can occur when you install a service pack. Applications that are designed with the updated libraries might depend on some changes that were made in the latest releases. The application might behave in unexpected ways if you transfer it to a user who has not installed the same libraries. To protect against this unexpected behavior, you can bind your application to a specific version of the libraries.

This section describes the default behavior of applications compiled with Visual C++ 2008 and later releases. When you compile an application, it is bound to the original release version of libraries available. This is true even if you have a later release installed on your computer. For example, if you have Visual C++ 2008 SP1 installed on your computer, any applications that you compile on this computer will still depend on the original release version of Visual C++ 2008.

This behavior is of no consequence if you deploy your application by installing in a central location. By using this distribution scheme, the latest libraries will always be available to the end user. However, if you use a local deployment method, such as with private assemblies as described in the topic How to: Deploy using XCopy, this behavior is important.

The default binding behavior enables you to recompile your program after you obtain a new release, and to distribute the new executable. The end users who already installed the necessary libraries will need only the new executable; you will not have to package and reinstall the latest libraries.

NoteNote:

If your application depends on functionality introduced in the latest release, you must distribute and reinstall the new libraries, or else the application will not run.

If you want to force your application to require that the latest libraries be installed on your computer, use one or more of the following lines of code:

#define _BIND_TO_CURRENT_CRT_VERSION 1
#define _BIND_TO_CURRENT_ATL_VERSION 1
#define _BIND_TO_CURRENT_MFC_VERSION 1
#define _BIND_TO_CURRENT_OPENMP_VERSION 1

To bind your application to the current version of all of the Visual C++ libraries, set _BIND_TO_CURRENT_VCLIBS_VERSION=1 on the C/C Preprocessor Definitions configuration page for every project in the solution. This is effectively a union of all the previous lines of code using command-line definition.

When you bind your application to a set of libraries, it will not run on a computer that has an earlier version of those libraries. If you bind your application to a specific minimum version, we recommend that you ship your application together with the required version of the libraries.

Date

History

Reason

July 2008

Added topic.

SP1 feature change.

September 2011

Clarified how to use _BIND_TO_CURRENT_VCLIBS_VERSION.

Customer feedback.

Community Additions

ADD
Show:
© 2014 Microsoft