Export (0) Print
Expand All

Troubleshooting Team Foundation Version Compatibility

Visual Studio 2008

Team Foundation Server and Team Explorer are available in two different versions: the version included in Visual Studio 2005 Team Foundation Server and the version included in Visual Studio Team System 2008 Team Foundation Server. Occasionally you might need to troubleshoot problems that arise from using different versions of Team Foundation Server and Team Explorer.

If you cannot resolve a problem after reviewing these tips, visit the Microsoft Technical Forums for Visual Studio Team System (http://go.microsoft.com/fwlink/?LinkId=54490). These forums provide searchable threads on a variety of troubleshooting topics. Also, these forums are monitored, so you can expect quick responses to your questions.

Symptom:   I see an error when I try to connect to Team Foundation Server. I have used Team Explorer successfully with Team Foundation Server in the past, but the administrator has instructed me to connect to a new Visual Studio Team System 2008 Team Foundation Server, or upgraded Team Foundation Server to Visual Studio Team System 2008 Team Foundation Server.

Possible Causes:

The version of Team Explorer you are using is the one included with Visual Studio 2005 Team Foundation Server. There is a known issue with the original version of Team Explorer and Team System 2008 Team Foundation Server when Team Foundation Server is configured to use Windows SharePoint Services 3.0. You can obtain an update from Microsoft Support Services, or upgrade Team Explorer to the version that is included with Visual Studio Team System 2008 Team Foundation Server. For more information, see Version Compatibility for Team Explorer and Version Compatibility for Team Foundation Server.

Symptom:   I see an error when I connect to Team Foundation Server and try to queue a build.

Possible Causes:

The version of Team Explorer you are using is the one included with Visual Studio 2005 Team Foundation Server. Some build features in Visual Studio Team System 2008 Team Foundation Server cannot be used with the Visual Studio 2005 Team Foundation Server version of Team Explorer. For more information, see Version Compatibility for Team Foundation Build.

Symptom:   A build computer I have been using suddenly will not work with Team Foundation Server.

Possible Causes:

Your administrator might have upgraded the version of Team Foundation Server to Visual Studio Team System 2008 Team Foundation Server. Your version of Team Foundation Build must match the version of Team Foundation Server. For more information, see Version Compatibility for Team Foundation Build.

Community Additions

ADD
Show:
© 2014 Microsoft