Export (0) Print
Expand All

Windows Vista and Visual Studio

You can install and use Visual Studio 2008 on Windows Vista. Support for earlier versions of Visual Studio on Windows Vista varies. Visual Studio 2005 with Service Pack 1 (SP1) Update for Windows Vista is supported on Windows Vista. Installation and use of earlier versions of Visual Studio on Windows Vista is not supported. Applications developed by using Visual Studio 2005 or Visual Studio .NET 2003 can be installed and used on Windows Vista.

Release

Install on Windows Vista?

Install applications developed with this version on Windows Vista?

Visual Studio 2008 

Yes

Yes

Visual Studio 2005 Service Pack 1 Update for Windows Vista

Yes

Yes

Visual Studio 2005 Service Pack 1

Yes

Yes

Visual Studio 2005 

No

Yes

Visual Studio .NET 2003 Service Pack 1

No

Yes, if the application targets .NET Framework 1.1 or later versions.

Visual Studio .NET 2003

No

Yes, if the application targets .NET Framework 1.1 or later versions.

Visual Studio .NET 2002

No

No

Installation and use of Visual Studio 2008 on Windows Vista is supported. You are not required to run Visual Studio 2008 under administrative permissions, but some features may require administrative permissions to work correctly. If a feature requires elevated access, a message box appears with additional instructions.

NoteNote:

If you install Visual Studio 2008 on Windows XP and then upgrade your operating system to Windows Vista, you must repair your Visual Studio 2008 installation to ensure that .NET Framework 3.5 works correctly.

Installation and use of Visual Studio 2005 on Windows Vista without installing one or more of the available service packs is not currently supported. You must install Visual Studio 2005 Service Pack 1, or Visual Studio 2005 Service Pack 1 and Visual Studio 2005 Service Pack 1 Update for Windows Vista, and run Visual Studio under administrative permissions for Visual Studio 2005 to be supported on Windows Vista. For more information, see How to: Find Product Updates.

Caution noteCaution:

If you plan to install Visual Studio 2005 Service Pack 1 Update for Windows Vista, you must first install Visual Studio 2005 Service Pack 1.

Applications developed with any release of Visual Studio 2005 will run on Windows Vista only if they target .NET Framework 1.1 or later.

For more information, see Visual Studio on Windows Vista.

Installation and use of Visual Studio .NET 2003 or Visual Studio .NET 2003 Service Pack 1 on Windows Vista is not currently supported. No updates for Visual Studio .NET 2003 related to Windows Vista are currently planned.

Applications developed with Visual Studio .NET 2003 or Visual Studio .NET 2003 Service Pack 1 will run on Windows Vista only if they target .NET Framework 1.1 or later.

Installation and use of Visual Studio .NET 2002 on Windows Vista is not supported.

Applications developed with Visual Studio .NET 2002 target .NET Framework 1.0, and therefore cannot run on Windows Vista. Only applications that target .NET Framework 1.1 or later are supported on Windows Vista. For more information, see Version Compatibility and What's New in the .NET Framework.

Community Additions

ADD
Show:
© 2014 Microsoft