Export (0) Print
Expand All

System Requirements

In order to use a third-party (or custom) backup and restore application and the Windows Server Volume Shadow Copy Service (VSS) to back up and restore Exchange 2010 databases, you must use the following applications:

  • Windows Server 2008 or later versions

  • Microsoft Exchange Server 2010

  • A third-party (or custom) application that is designed to use VSS to back up and restore Exchange 2010 databases.

In addition, if you are creating a backup and restore application, you should be aware of the following restrictions on the development environment:

  • VSS is an unmanaged COM API that can be accessed from Microsoft .NET managed code via a COM Interop Assembly.

  • PowerShell is a managed application that is accessed via Microsoft .NET managed code.

  • The CHKSGFILES API that is supplied with Exchange 2010 is a native-code 64-bit DLL. This differs from Exchange 2007, where CHKSGFILES was a 32-bit DLL. Exchange 2010 does not provide a 32-bit CHKSGFILES library. Microsoft does not support attempting to use the Exchange 2007 32-bit CHKSGFILES DLL with Exchange 2010 databases.

Show:
© 2014 Microsoft