Export (0) Print
Expand All

System Requirements for Version 2.0

.NET Framework 3.5

To ensure adequate performance, the Microsoft .NET Framework version 2.0 has the following minimum and recommended system requirements for client and server applications.

NoteNote:

For the most up-to-date information on system requirements and supported platforms, see the Readme.htm file for the .NET Framework. If you have installed the stand-alone SDK, the Readme file is located in the Program Files\Microsoft.NET\SDK\v2.0\subdirectory. If you have installed the .NET Framework as part of Visual Studio 2005, the Readme file is located in the Program Files\Microsoft Visual Studio 8\SDK\v2.0 subdirectory.

The .NET Framework can be installed on the following platforms and operating systems. For information about the .NET Compact Framework support for mobile platforms, see Devices and Platforms Supported by the .NET Compact Framework.

Scenario

Target platforms

x32-bit based systems

Windows 98

Windows 98 Second Edition

Windows 2000 Professional with SP4

Windows 2000 Server with SP4

Windows 2000 Advanced Server with SP4

Windows 2000 Datacenter Server with SP4

Windows XP Professional with SP2

Windows XP Home Edition with SP2

Windows XP Media Center Edition 2002 with SP2

Windows XP Media Center Edition 2004 with SP2

Windows XP Media Center Edition 2005

Windows XP Tablet PC Edition with SP2

Windows XP Starter Edition

Windows Millennium Edition

Windows Server 2003 Standard Edition

Windows Server 2003 Enterprise Edition

Windows Server 2003 Datacenter Edition

Windows Server 2003 Web Edition

Windows Server 2003 R2, Standard Edition

Windows Server 2003 R2, Enterprise Edition

Windows Server 2003 R2, Datacenter Edition

Windows Vista Starter (included with operating system)

Windows Vista Home Basic (included with operating system)

Windows Vista Home Premium (included with operating system)

Windows Vista Ultimate (included with operating system)

Windows Vista Business (included with operating system)

Windows Server 2008 Standard 32-Bit (included with operating system)

Windows Server 2008 Enterprise 32-Bit (included with operating system)

Windows Server 2008 Datacenter 32-Bit (included with operating system)

x64-bit based systems

Windows XP Professional x64 Edition

Windows Server 2003, Standard x64 Edition

Windows Server 2003, Enterprise x64 Edition

Windows Server 2003, Datacenter x64 Edition

Windows Server 2003 R2, Standard x64 Edition

Windows Server 2003 R2, Enterprise x64 Edition

Windows Server 2003 R2, Datacenter x64 Edition

Windows Vista Home Premium 64-bit Edition (included with operating system)

Windows Vista Ultimate 64-bit Edition (included with operating system)

Windows Vista Business 64-bit Edition (included with operating system)

The 64-bit edition of Windows Server 2008 Standard (included with operating system)

The 64-bit edition of Windows Server 2008 Enterprise (included with operating system)

The 64-bit edition of Windows Server 2008 Datacenter (included with operating system)

NoteNote:

  Supported on WOW64.

Itanium-based systems

Windows Server 2003 with SP1, Enterprise Edition for Itanium-based Systems

Windows Server 2003 with SP1, Datacenter Edition for Itanium-based Systems

Windows Server 2003 R2, Enterprise Edition for Itanium-based Systems

Windows Server 2003 R2, Datacenter Edition for Itanium-based Systems

Windows Server 2008 Enterprise for Itanium-based Systems (included with operating system)

.NET Compact Framework

Windows Mobile for Pocket PC

Windows Mobile for Smartphone

Windows CE

NoteNote:

For information about the .NET Compact Framework support for mobile platforms, see Devices and Platforms Supported by the .NET Compact Framework.

The following table provides system requirements if you use Visual Studio as your development environment.

Scenario

Development platforms

x32-bit based systems

Windows 2000 Professional with SP4

Windows 2000 Server with SP4

Windows 2000 Advanced Server with SP4

Windows 2000 Datacenter Server with SP4

Windows XP Professional with SP2

Windows XP Home Edition with SP2

Windows XP Media Center Edition 2002 with SP2

Windows XP Media Center Edition 2004 with SP2

Windows XP Media Center Edition 2005

Windows XP Tablet PC Edition with SP2

Windows Server 2003 with SP1, Standard Edition

Windows Server 2003 with SP1, Enterprise Edition

Windows Server 2003 with SP1, Datacenter Edition

Windows Server 2003 with SP1, Web Edition

Windows Server 2003 R2, Standard Edition

Windows Server 2003 R2, Enterprise Edition

Windows Server 2003 R2, Datacenter Edition

x64-bit based systems

Windows XP Professional x64 Edition

Windows Server 2003, Standard x64 Edition

Windows Server 2003, Enterprise x64 Edition

Windows Server 2003, Datacenter x64 Edition

Windows Server 2003 R2, Standard x64 Edition

Windows Server 2003 R2, Enterprise x64 Edition

Windows Server 2003 R2, Datacenter x64 Edition

NoteNote:

Supported on WOW64.

The .NET Framework cannot be installed on the following operating systems.

Scenario

Operating system

All platforms

Windows 95

Windows NT Server

Windows NT Workstation

Windows Server 2003, Enterprise Edition for Itanium-based Systems

Windows Server 2003, Datacenter Edition for Itanium-based Systems

Minimum Software

  • Microsoft Internet Explorer 6.0 with Service Pack 1.

  • Microsoft Data Access Components (MDAC) 2.8 for data access applications.

  • Windows Installer version 3.0.

Processors

Scenario

Minimum

.NET Framework redistributable

400 megahertz (MHz)

Windows Software Development Kit (SDK)

600 MHz

RAM

Scenario

Minimum

.NET Framework

96 megabytes (MB)

Windows Software Development Kit (SDK)

128 MB

Hard Disk Space

Scenario

Minimum

32-bit

280 MB

64-bit

610 MB

It is highly recommended for all platforms that you upgrade to the latest Windows Service Pack and critical updates available from http://www.windowsupdate.com to ensure the best compatibility and security.

The Windows Software Development Kit (SDK) requires Windows 2000 or later operating system with Microsoft Internet Explorer 6.0 with Service Pack 1 installed. The Windows SDK also requires that the .NET Framework version 2.0 be installed before installing the SDK. The 64-bit Windows SDK requires Windows XP Professional x64 Edition or Windows Server 2003, Standard x64 Edition with Service Pack 1.

Community Additions

ADD
Show:
© 2014 Microsoft