Export (0) Print
Expand All

Minimum Configuration Requirements

This section describes the minimum configuration requirements for a computer where Dotnetfx.exe is to be installed. If the minimum requirements are not met, Dotnetfx.exe setup will block the installation of the redistributable package. Specifically, note that you cannot install the .NET Framework on a computer running the Microsoft Windows 95 operating system.

Platform and Software Requirements

Minimum requirements

To install Dotnetfx.exe, you must have one of the following operating systems with Microsoft Internet Explorer 5.01 or later installed on your computer:

  • Microsoft® Windows® 98

  • Microsoft® Windows® 98 Second Edition

  • Microsoft® Windows® Millennium Edition (Windows Me)

  • Microsoft® Windows NT® 4 (Workstation or Server) with Service Pack 6a

  • Microsoft® Windows® 2000 (Professional, Server, or Advanced Server) with the latest Windows service pack and critical updates available from the Microsoft Security Web site (www.microsoft.com/security).

  • Microsoft® Windows® XP (Home or Professional)

  • Microsoft® Windows® Server 2003 family

    Caution noteCaution

    If you install Dotnefx.exe on Windows Server 2003 Beta 3, you will break the version of the .NET Framework that is installed with the operating system. Windows Server 2003 Beta 3 installs version 1.0.3215 of the .NET Framework. If you install a later version of the .NET Framework, version 1.0.3215 will be broken. If you install a later version, you can run and use the later version. However, you will not be able to use version 1.0.3215, even after uninstalling the later version.

Recommended software

Depending on your application requirements, you might also need to install one or more of the following:

  • MDAC 2.6 or later for data access, available from the Universal Data Access Web site.

  • Core WMI for Windows instrumentation, available from the Microsoft MSDN Download Center Web site at www.msdn.microsoft.com/downloads/?url=/downloads/sample.asp?url=/msdn-files/027/001/576/msdncompositedoc.xml&frame=true.

    NoteNote

    If the recommended software requirements are not met, setup will not block installation or warn you of their absence.

Recommended server software

Depending on your application requirements, you might also need the following server software:

  • MDAC 2.7 for data on the server, available at the Universal Data Access Web site.

  • Internet Information Services (IIS) on the server for Windows 2000, Windows XP (Professional), and Windows Server 2003. This is required for using ASP.NET applications.

Hardware Requirements

Minimum hardware requirements
Scenario CPU Required RAM Required

Client

Pentium 90 MHz*

32 MB**

Server

Pentium 133 MHz*

128 MB**

* Or the minimum CPU required to run the operating system, whichever is higher.

** Or the minimum RAM required to run the operating system, whichever is higher.

Recommended hardware
Scenario CPU Recommended RAM Recommended

Client

Pentium 90 MHz or faster

96 MB or higher

Server

Pentium 133 MHz or faster

256 MB or higher

See Also

Community Additions

ADD
Show:
© 2014 Microsoft