Export (0) Print
Expand All
This topic has not yet been rated - Rate this topic

OracleCommandBuilder.GetUpdateCommand Method (Boolean)

Note: This method is new in the .NET Framework version 2.0.

Gets the automatically generated OracleCommand object required to perform updates on the database.

Namespace: System.Data.OracleClient
Assembly: System.Data.OracleClient (in system.data.oracleclient.dll)

public OracleCommand GetUpdateCommand (
	bool useColumnsForParameterNames
)
public OracleCommand GetUpdateCommand (
	boolean useColumnsForParameterNames
)
public function GetUpdateCommand (
	useColumnsForParameterNames : boolean
) : OracleCommand

Parameters

useColumnsForParameterNames

If true, generate parameter names matching column names, if possible. If false, generate @p1, @p2, and so on.

Return Value

The automatically generated OracleCommand object required to perform updates.

You can use the GetUpdateCommand method for informational or troubleshooting purposes because it returns the OracleCommand object to be executed.

You can also use GetUpdateCommand as the basis of a modified command. For example, you might call GetUpdateCommand and modify the CommandText value, and then explicitly set that on the OracleDataAdapter.

The SQL statements are first generated when the application calls either Update or GetUpdateCommand.

The default behavior, when generating parameter names, is to use @p1, @p2, and so on for the various parameters. Passing true for the useColumnsForParameterNames parameter allows you to force the DbCommandBuilder to generate parameters based on the column names instead. . This succeeds only if the following conditions are met:

For more information, see Automatically Generating Commands.

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

.NET Framework

Supported in: 2.0
Did you find this helpful?
(1500 characters remaining)
Thank you for your feedback

Community Additions

ADD
Show:
© 2014 Microsoft. All rights reserved.