Export (0) Print
Expand All

WebProxy.GetDefaultProxy Method

NOTE: This API is now obsolete.

Reads the Internet Explorer nondynamic proxy settings.

Namespace:  System.Net
Assembly:  System (in System.dll)

'Declaration
<ObsoleteAttribute("This method has been deprecated. Please use the proxy selected for you by default. http://go.microsoft.com/fwlink/?linkid=14202")> _
Public Shared Function GetDefaultProxy As WebProxy
'Usage
Dim returnValue As WebProxy 

returnValue = WebProxy.GetDefaultProxy()

Return Value

Type: System.Net.WebProxy
A WebProxy instance that contains the nondynamic proxy settings from Internet Explorer 5.5 and later.

The GetDefaultProxy method reads the nondynamic proxy settings stored by Internet Explorer 5.5 and later, and creates a WebProxy instance with those settings.

The GetDefaultProxy method does not pick up any dynamic settings that are generated from scripts run by Internet Explorer, from automatic configuration entries, or from DHCP or DNS lookups.

The following code example demonstrates calling this method.

No code example is currently available or this language may not be supported.
void CheckDefaultProxyForRequest(Uri* resource)
{
    WebProxy* proxy = dynamic_cast<WebProxy*> (WebProxy::GetDefaultProxy());

    // See what proxy is used for resource.
    Uri* resourceProxy = proxy->GetProxy(resource);

    // Test to see whether a proxy was selected.
    if (resourceProxy == resource)
    {
        Console::WriteLine(S"No proxy for {0}", resource);
    } 
    else
    {
        Console::WriteLine(S"Proxy for {0} is {1}", resource,
            resourceProxy);
    }
}

Windows 7, Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2008 R2, Windows Server 2008, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98, Windows CE, Windows Mobile for Smartphone, Windows Mobile for Pocket PC

The .NET Framework and .NET Compact Framework do not support all versions of every platform. For a list of the supported versions, see .NET Framework System Requirements.

.NET Framework

Supported in: 1.1, 1.0
Obsolete (compiler warning) in 3.5
Obsolete (compiler warning) in 3.5 SP1
Obsolete (compiler warning) in 3.0
Obsolete (compiler warning) in 3.0 SP1
Obsolete (compiler warning) in 3.0 SP2
Obsolete (compiler warning) in 2.0
Obsolete (compiler warning) in 2.0 SP1
Obsolete (compiler warning) in 2.0 SP2

.NET Compact Framework

Supported in: 1.0
Obsolete (compiler warning) in 3.5
Obsolete (compiler warning) in 2.0

Community Additions

ADD
Show:
© 2014 Microsoft