Export (0) Print
Expand All

BaseVsaEngine Class

NOTE: This class is now obsolete.

Namespace: Microsoft.Vsa
Assembly: Microsoft.JScript (in microsoft.jscript.dll)

'Declaration
<ObsoleteAttribute("Use of this type is not recommended because it is being deprecated in Visual Studio 2005; there will be no replacement for this feature. Please see the ICodeCompiler documentation for additional help.")> _
<ComVisibleAttribute(True)> _
<GuidAttribute("F8932A50-9127-48B6-B115-2BFDC627CEE3")> _
Public MustInherit Class BaseVsaEngine
	Implements IVsaEngine
'Usage
Dim instance As BaseVsaEngine

/** @attribute ObsoleteAttribute("Use of this type is not recommended because it is being deprecated in Visual Studio 2005; there will be no replacement for this feature. Please see the ICodeCompiler documentation for additional help.") */ 
/** @attribute ComVisibleAttribute(true) */ 
/** @attribute GuidAttribute("F8932A50-9127-48B6-B115-2BFDC627CEE3") */ 
public abstract class BaseVsaEngine implements IVsaEngine
ObsoleteAttribute("Use of this type is not recommended because it is being deprecated in Visual Studio 2005; there will be no replacement for this feature. Please see the ICodeCompiler documentation for additional help.") 
ComVisibleAttribute(true) 
GuidAttribute("F8932A50-9127-48B6-B115-2BFDC627CEE3") 
public abstract class BaseVsaEngine implements IVsaEngine

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

.NET Framework

Supported in: 1.0, 1.1
Obsolete (compiler warning) in 2.0

Community Additions

ADD
Show:
© 2014 Microsoft