(0) exportieren Drucken
Alle erweitern
Dieser Artikel wurde maschinell übersetzt. Bewegen Sie den Mauszeiger über die Sätze im Artikel, um den Originaltext anzuzeigen. Weitere Informationen
Übersetzung
Original

IDesignerVerbProviderService-Schnittstelle

Hinweis: Diese API ist mittlerweile veraltet.

Ermöglicht es Aktivitätsdesignerentwicklern, einem Aktivitätsdesigner benutzerdefinierte Designerverbanbieter hinzuzufügen.

Namespace:  System.Workflow.ComponentModel.Design
Assembly:  System.Workflow.ComponentModel (in System.Workflow.ComponentModel.dll)

[ObsoleteAttribute("The System.Workflow.* types are deprecated.  Instead, please use the new types from System.Activities.*")]
public interface IDesignerVerbProviderService

Der IDesignerVerbProviderService-Typ macht die folgenden Member verfügbar.

  NameBeschreibung
Öffentliche EigenschaftVerbProvidersRuft eine schreibgeschützte IDesignerVerbProvider-Auflistung ab.
Zum Seitenanfang

  NameBeschreibung
Öffentliche MethodeAddVerbProviderFügt der von einem ActivityDesigner verwendeten Liste von Verbanbietern eine Klasse hinzu, die die IDesignerVerbProvider-Schnittstelle implementiert.
Öffentliche MethodeRemoveVerbProviderEntfernt eine Klasse, die die IDesignerVerbProvider-Schnittstelle implementiert, aus der von einem ActivityDesigner verwendeten Liste von Verbanbietern.
Zum Seitenanfang

HinweisHinweis

In diesem Material werden veraltete Typen und Namespaces erläutert. Weitere Informationen finden Sie unter Veraltete Typen in Windows Workflow Foundation 4.5.

Klassen, die diese Schnittstelle implementieren, können benutzerdefinierte Verbanbieter zu ActivityDesigner-Klassen hinzufügen und aus diesen Klassen entfernen. Dazu zählen alle Klassen, die die IDesignerVerbProvider-Schnittstelle implementieren.

.NET Framework

Unterstützt in: 4, 3.5, 3.0
Veraltet (Compilerwarnung) in 4.5.2
Veraltet (Compilerwarnung) in 4.5.1
Veraltet (Compilerwarnung) in 4.5

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core-Rolle wird nicht unterstützt), Windows Server 2008 R2 (Server Core-Rolle wird mit SP1 oder höher unterstützt; Itanium wird nicht unterstützt)

.NET Framework unterstützt nicht alle Versionen sämtlicher Plattformen. Eine Liste der unterstützten Versionen finden Sie unter Systemanforderungen für .NET Framework.

Community-Beiträge

HINZUFÜGEN
Anzeigen:
© 2014 Microsoft