(0) exportieren Drucken
Alle erweitern
Erweitern Minimieren

LIBFLAGS-Enumeration

HINWEIS: Diese Enumeration ist mittlerweile veraltet.

Verwenden Sie stattdessen LIBFLAGS.

Diese Enumeration verfügt über ein FlagsAttribute -Attribut, das die bitweise Kombination der Memberwerte zulässt.

Namespace: System.Runtime.InteropServices
Assembly: mscorlib (in mscorlib.dll)

[SerializableAttribute] 
[ObsoleteAttribute("Use System.Runtime.InteropServices.ComTypes.LIBFLAGS instead. http://go.microsoft.com/fwlink/?linkid=14202", false)] 
[FlagsAttribute] 
public enum LIBFLAGS : short
/** @attribute SerializableAttribute() */ 
/** @attribute ObsoleteAttribute("Use System.Runtime.InteropServices.ComTypes.LIBFLAGS instead. http://go.microsoft.com/fwlink/?linkid=14202", false) */ 
/** @attribute FlagsAttribute() */ 
public enum LIBFLAGS
SerializableAttribute 
ObsoleteAttribute("Use System.Runtime.InteropServices.ComTypes.LIBFLAGS instead. http://go.microsoft.com/fwlink/?linkid=14202", false) 
FlagsAttribute 
public enum LIBFLAGS

 MembernameBeschreibung
LIBFLAG_FCONTROLDie Typbibliothek beschreibt Steuerelemente und sollte nicht in Typbrowsern angezeigt werden, die für nichtvisuelle Objekte bestimmt sind. 
LIBFLAG_FHASDISKIMAGEDie Typbibliothek steht auch dauerhaft auf der Festplatte zur Verfügung. 
LIBFLAG_FHIDDENDie Typbibliothek sollte Benutzern nicht angezeigt werden, obwohl ihre Verwendung nicht eingeschränkt ist. Muss von Steuerelementen verwendet werden. Hosts müssen eine neue Typbibliothek erzeugen, die einen Wrapper für das Steuerelement mit erweiterten Eigenschaften erstellt. 
LIBFLAG_FRESTRICTEDDie Typbibliothek unterliegt Beschränkungen und sollte Benutzern nicht angezeigt werden. 

Weitere Informationen über die LIBFLAGS-Enumeration finden Sie in der MSDN Library.

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

.NET Framework unterstützt nicht alle Versionen sämtlicher Plattformen. Eine Liste der unterstützten Versionen finden Sie unter Systemanforderungen.

.NET Framework

Unterstützt in: 1.0, 1.1
Veraltet (Compilerwarnung) in 2.0
Anzeigen:
© 2014 Microsoft