(0) exportieren Drucken
Alle erweitern

OleDbConnection.ServerVersion-Eigenschaft

Aktualisiert: November 2007

Ruft eine Zeichenfolge mit der Version des Servers ab, mit der der Client verbunden ist.

Namespace:  System.Data.OleDb
Assembly:  System.Data (in System.Data.dll)

public override string ServerVersion { get; }
/** @property */
public String get_ServerVersion()

public override function get ServerVersion () : String

Eigenschaftenwert

Typ: System.String
Die Version des verbundenen Servers.

AusnahmeBedingung
InvalidOperationException

Die Verbindung ist geschlossen.

Die ServerVersion-Eigenschaft nimmt Zuordnungen zur OLE DB DBPROP_DBMSVER-Eigenschaft vor. Wenn die ServerVersion vom zugrunde liegenden OLE DB-Anbieter nicht unterstützt wird, wird eine leere Zeichenfolge zurückgegeben.

Die Version hat das Format ##.##.####, wobei die ersten beiden Ziffern die Hauptversion, die folgenden beiden Ziffern die Nebenversion und die letzten vier Ziffern die Releaseversion sind. Der Provider muss die Produktversion in diesem Format darstellen, jedoch kann auch die produktspezifische Version angefügt werden (z. B. "04.01.0000 Rdb 4.1"). Die Zeichenfolge hat das Format Haupt.Neben.Build, wobei Haupt- und Nebenversion jeweils genau zwei Ziffern enthalten und Build genau vier Ziffern enthält.

Im folgenden Beispiel wird eine OleDbConnection erstellt, und einige ihrer schreibgeschützten Eigenschaften werden angezeigt.

static void OpenConnection(string connectionString)
{
    using (OleDbConnection connection = new OleDbConnection(connectionString))
    {
        try
        {
            connection.Open();
            Console.WriteLine("ServerVersion: {0}", connection.ServerVersion);
        }
        catch (Exception ex)
        {
            Console.WriteLine(ex.Message);
        }
        // The connection is automatically closed when the
        // code exits the using block.
    }
}


Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98

.NET Framework und .NET Compact Framework unterstützen nicht alle Versionen sämtlicher Plattformen. Eine Liste der unterstützten Versionen finden Sie unter Systemanforderungen für .NET Framework.

.NET Framework

Unterstützt in: 3.5, 3.0, 2.0, 1.1, 1.0

Community-Beiträge

HINZUFÜGEN
Anzeigen:
© 2014 Microsoft